Feb 22, 2013

Configuring Ethernet Interfaces

The configuration tasks for Ethernet interfaces are quite simple. In fact, you only need to assign the IP address and remove the interface from shutdown mode. Because the configuration tasks are so straightforward, an overview of Ethernet technology is not really necessary here. Begin with a review of the routers that have Ethernet interfaces that you will need to configure. Figure 7-5 illustrates the Ethernet interfaces on the routers.

07fig05.gif Figure 7-5 Ethernet Routers
Start with configuring R1, then configure R2, and go up to R4. To assign the IP address and remove the interface from shutdown mode, you need to be in interface configuration mode for the Ethernet interface. Example 7-34 takes you through the process of configuring the Ethernet interface on R1. Refer to Figure 7-5 for the interface number, IP address, and subnet mask.

Example 7-34. R1 Ethernet Configuration

R5#<ctrl-shft-6-x>
    Termserver#1
[Resuming connection 1 to r1 ... ]

R1#config t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface ethernet0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#description This interface connects to R2's E0
R1(config-if)#no shut
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
R1(config-if)#
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1(config-if)#
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
R1's Ethernet 0 came up fine, so go to R2. Example 7-35 demonstrates the steps in configuring R2's Ethernet interfaces.

Example 7-35. R2 Ethernet Interface Configuration

R1#copy running-config startup-config
Building configuration...
[OK]
R1#<ctrl-shft-6><x>
    Termserver#2
[Resuming connection 2 to r2 ... ]

R2#
R2#config t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface ethernet 0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#description This interface connects to R1's E0
R2(config-if)#no shutdown
R2(config-if)#
1d17h: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
1d17h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state
to up
R2(config-if)#
R2(config-if)#exit
R2(config)#interface ethernet 1
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R1(config-if)#description This interface does not connect with another IP device
R2(config-if)#no shutdown
R2(config-if)#
1d17h: %LINK-3-UPDOWN: Interface Ethernet1, changed state to up
1d17h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet1, changed state
to up
R2(config-if)#
Both Ethernet interfaces came up. You should be capable of pinging R1's Ethernet 0 interface for R2, as demonstrated in Example 7-36.

Example 7-36. R2 to R1 ping Results

R2(config-if)#end
R2#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
R2#
Okay, R1 and R2 have IP connectivity. You can verify that Ethernet 1 is functional by looking at the interface. Example 7-37 shows the output of the show interfaces command, which displays all of R2's interfaces; however, only the Ethernet interfaces are of interest for this part of the lab.

Example 7-37. show interfaces Command Output on R2

R2#show interfaces
Ethernet0 is up, line protocol is up
  Description: This interface connects to R1's E0
  Hardware is QUICC Ethernet, address is 0010.7bf9.4912 (bia 0010.7bf9.4912)
  Internet address is 192.168.1.2/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
  Encapsulation ARPA, loopback not set, keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:20, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     41 packets input, 4110 bytes, 0 no buffer
     Received 36 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     159 packets output, 16101 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Ethernet1 is up, line protocol is up
  Hardware is QUICC Ethernet, address is 0010.7bf9.4913 (bia 0010.7bf9.4913)
  Description: This interface does not connect with another IP device
  Internet address is 192.168.2.2/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
  Encapsulation ARPA, loopback not set, keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:23, output 00:00:09, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     19 packets input, 1729 bytes, 0 no buffer
     Received 19 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     136 packets output, 13770 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
 --More--
The most important information right now is to see that both interfaces are up. This signifies that link keepalives are being exchanged between the interfaces and the switch. No other devices exist off Ethernet 1, so you cannot verify connectivity. However, because both interfaces are up, you can assume that they are configured and working properly.
Example 7-38 consolidates the configuration of both R3 and R4 to save time. Make sure that you see the console messages stating that the interfaces are up, but there is no need to ping anything at this point. Be sure to look at the subnet mask on R4's Ethernet 0. It has a mask of /27. That is a 255.255.255.224 mask in decimal notation.

Example 7-38. R3 and R4 Ethernet Configuration

R2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R2#<ctrl-shft-6><x>
    Termserver#3
[Resuming connection 3 to r3 ... ]

R3#config t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#interface ethernet 0
R3(config-if)#ip address 192.168.3.3 255.255.255.0
R3(config-if)#description This interface does not connect with another IP device
R3(config-if)#no shutdown
R3(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
R3(config-if)#
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
R3(config-if)#end
R3#
%SYS-5-CONFIG_I: Configured from console by console
R3#copy running-config  startup-config
Building configuration...
[OK]
R3#<ctrl-shft-6><x>
    Termserver#4
[Resuming connection 4 to r4 ... ]

R4#config t
Enter configuration commands, one per line. End with CNTL/Z.
R4(config)#interface  ethernet 0
R4(config-if)#ip address 192.168.4.4 255.255.255.224
Bad mask /27 for address 192.168.4.4
R4(config-if)#
Notice the error message "Bad mask /27 for address 192.168.4.4." Why is /27 (or 255.255.255.2250) a bad mask? In IP subnetting, you cannot use the first group of IP addresses or the last group of a subnetted address space. Does 192.168.4.4 fall into the first group of addresses? To find out, break up the /27 bit mask (255.255.255.224). The result is eight different groups of IP addresses:
  • 0 to 31
  • 32 to 63
  • 64 to 95
  • 96 to 127
  • 128 to 159
  • 160 to 191
  • 192 to 123
  • 224 to 255
The address of 192.168.4.4 does fall into the first group. Cisco has a command that will overcome this limitation:
Router(config)#ip subnet-zero
There are no options on this command, and it is executed under global configuration mode. This command enables you to use the first and last groups of a subnetted address space. Example 7-39 uses this command to configure R4.

Example 7-39. R4 Configuration for ip subnet-zero

R4(config-if)#exit
R4(config)#ip subnet-zero
R4(config)#interface ethernet 0
R4(config-if)#ip address 192.168.4.4 255.255.255.224
R4(config)-if)#$cription This interface does not connect with another IP device
R4(config-if)#no shutdown
R4(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
R4(config-if)#
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
R4(config-if)#end
%SYS-5-CONFIG_I: Configured from console by console
R4#copy running-config startup-config
Building configuration...
[OK]
R4#
You get no error messages this time. The IP address successfully is assigned to the interface and is removed from the shutdown state. Console messages indicate that the interface and line protocol for Ethernet 0 are up. The configuration is saved, and you are ready to configure the Token Ring interfaces on R5 and R6.

0 comments:

Post a Comment

Twitter Delicious Facebook Digg Stumbleupon Favorites More

 
Design by Computer Tricks and Tips